Degrated application performance

Incident Report for Transifex

Postmortem

Service-to-Service Communication Degradation

Summary
During the incident, we observed intermittent, seemingly random delays when refreshing the application at app.transifex.com. These delays affected the handling of customer requests and overall platform responsiveness.

Investigation & Findings
Following the initial reports, we investigated our load balancer logs and identified an unusually high volume of requests between our core service and the Transifex-delivery service.
By correlating the load balancer logs with our application logs, we determined that a substantial number of requests were being throttled and retried between those services. This led to performance degradation when handling incoming requests on our main platform.

Impact
The issue caused performance degradation across our platform at irregular time intervals.

Mitigation & Resolution
As part of scheduled maintenance, we temporarily paused translation activity to adjust certain configurations.
After the maintenance changes were applied, translation activity was re-enabled. However, the system did not immediately return to a fully stable state. To ensure reliable request handling and prevent further performance degradation, we made additional adjustments to the affected language configurations to reduce internal service load and fully stabilize the platform.
Once system stability was fully confirmed, all affected languages and their translations were restored, and the platform was gradually returned to full functionality.

Preventive Actions & Improvements
To reduce the risk of similar issues occurring in the future, we have introduced improvements to how requests are handled between our core platform services and the Transifex-delivery service, including configuring throttling and retry mechanisms.

Posted Dec 09, 2025 - 10:38 UTC

Resolved

The incident has been resolved, and everything is now working as expected.
Thank you so much for your patience, and apologies for the disruption earlier!
Posted Dec 04, 2025 - 16:47 UTC

Monitoring

The app performance degradation has been resolved after the fix we implemented. We are now monitoring the system performance to ensure everything remains stable. Thank you for your patience.
Posted Dec 04, 2025 - 14:47 UTC

Identified

The issue has been identified, and a fix is being implemented.
Posted Dec 04, 2025 - 14:33 UTC

Update

We are still investigating the issue. We apologize for any inconvenience this issue has caused you.
Posted Dec 04, 2025 - 13:34 UTC

Investigating

We are currently investigating the issue.
Posted Dec 04, 2025 - 11:39 UTC
This incident affected: Transifex App.